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How to analyze
the conformational properties

of a small molecule



How to build imipramine

You can build molecules by two different approaches:

• Built-in 3D molecular editor.

• 2D molecular editor (e.g. ISIS/Draw 2.5, JME, JChemPaint, Sketchel etc.)
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3D molecular editor

The 3D editor is based on fragments databases containing building blocks that can be 
combined each other to complete a more complex structure. For this reason, you must 
fragment the molecule in less complex fragments that will be assembled as indicated in the 
following scheme:
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Excluding initially the heteroatoms, the system can be fragmented in:

• #1 tricyclic system (Dibenzo[a,d]cycloheptane);

• #1 n-butyl chain;

• #2 methyl groups.



Building the molecule1

• Select Edit → Add → Fragments in the menu bar and the Add fragment/s
window will appear.

• Choose Rings (aromatic) in the Group box and 15 5H-
Dibenzo[a,d]cycloheptane in the Fragment box.

• Click the Finish and thus Close buttons. The starting building block is 
shown in the workspace:

15 5H-Dibenzo[a,d]cycloheptane fragment 



Building the molecule2

• In order to change the C5 carbon to a nitrogen and to remove one 
hydrogen connected to it, select Edit → Change → Atom/residue/chain in 
the menu bar.

• Click the C5 as indicated by the red arrow in the following picture:

• In the Element field of the Edit dialog, change C to N, click the Apply
button and close the window. The atom color will change from green to 
blue.



Building the molecule3

• Rotating the molecule, highlight the two hydrogens bonded to N5.

• To remove one hydrogen, select Edit → Remove → Atom and click the 
atom to remove as indicated by the red arrow:

The hydrogen will be deleted. Click the Done button to close the window.



Building the molecule4

• To add the n-butyl chain, reopen the Add fragment/s window (Edit → Add 
→ Fragments), search 04C n-Butane in the Alkanes group and click the 
Next button.

• Click the butane hydrogen that will be merged with the hydrogen bonded 
to N5 (see red arrow):

• Click the Next button and the tricyclic system will be shown. Click the 
hydrogen bonded to N5:



Building the molecule5

• Click Next and thus the Finish buttons. Close the window.

• At this step, you must change the C4 of the n-butyl chain to a nitrogen and 
remove a hydrogen: select Edit → Change → Atom/residue/chain and 
click the C4 as indicated by the red arrow:

• In the Element field of the Edit dialog, change C to N, click the Apply
button and close the window.



Building the molecule6

• To remove one hydrogen, select Edit → Remove → Atom and click the 
atom to remove:

• Click the Done button to close the window.

• Finally you must add the two methyl groups to the N4 of the n-butyl chain. 
Open the Add fragment/s window (Edit → Add → Fragments).



Building the molecule7

• In the Alkanes group select 01C Methane and click Next.

• Click a methane hydrogen and the Next button.

• Click a hydrogen of the ammine:

• Click Next and Finish.

• Repeat the same steps to add the second methyl group:

• Save the molecule in IFF format (File → Save As...) with the imipramine.iff
file name.



Structure optimization by MM

• Assign the atom types and the charges (Calculate → Charge & Pot.), 
checking Force field and Charges and selecting SP4 and Gasteiger. Click 
the Fix button. The total charge is 0.

• Open the Ammp minimization window selecting Calculate -> Ammp -> 
Minimization in the menu bar.

• Choose Conjugate gradients and set Minimization steps to 1000 and Toler
to 0.01.

• Click the Run button. After few steps, the minimization is completed.

• Save the molecule in IFF format overwriting the previous one.



Semi-empirical calculation with Mopac

• Open the Mopac calculation window, selecting Calculate → Mopac in the 
main menu.

• In the Parameters box, select AM1 in the Calculate field, keep checked 
the Precise and GEO-OK items.

• Clicking the Run button, the file requester is shown. Keep the default file 
name and click the Save button to start the calculation. The graphic will be 
updated during the calculation only if Mopac 2007-2009 is installed.

• Normalize the atom coordinates (Edit → Coordinates → Normalize).

• Save the molecule in IFF format overwriting the previous one.



Conformational search1

In order to find a reasonable lowest energy conformation, a conformational search 
will be performed. The flexible torsions (dihedrals) will be systematically rotated by 
an angle value (grid scan) and each conformation will be optimized in order to find 
the best minimum.

• Open the Ammp conformational search window (Calculate → Ammp →
Conformational search).

• Click the Edit torsion button. The Selection tool window will appear.

• In its menu bar, select Edit → Add flexible torsions and all flexible torsion 
will be automatically added in the selection list (4 torsions). They are 
highlighted in the workspace also.

• Click Done and the Ammp conformational search window is shown.

• Select Systematic in the Method field of the Search parameters box. 



Conformational search2

The upper box shows the torsions that will be rotated during the scan. Increasing 
the number of rotation steps (see the Steps field in the Torsion parameters box), the 
search is more accurate but more computational time is required. The value of 6 is a 
good choice because it means a rotation of 60 degrees for each step.

• Check Trajectory, Output and Energy in the left box. Please remember to 
set the Graphic update to 1, otherwise not all conformations will be stored 
in the output files.

• Check Minimize all 
conformations.

• Put 100 in the Steps field 
and 0.01 in the Toler field.



Conformational search3

• Click the Run button to start the calculation. In the console will be shown 
for each conformation the starting energy, the best energy found at that 
time, and the energy after the minimization.

• After few minutes, the search is finish and the best conformation is 
automatically loaded in the workspace.

• To refine this structure, repeat the energy minimization as explained 
above and save the final molecule.

WARNING:

Remember to uncheck the Trajectory, Output and Energy fields, otherwise 
the conformational search outputs will be lost.



Cluster analysis

You need to perform a cluster analysis of the conformations generated by the 
conformational search because, due to the energy minimization, some of them are 
similar (= they are the same energy minimum). The cluster analysis allows to 
discard similar conformation that are redundant for other analyses.

• Open the file imipramine.dcd (File → Open) and click Replace in the 
Molecule placing window. The Trajectory analysis window will be shown.

• Choose the Cluster tab. In the Method box, select Torsion RMSD and put 
60 (degrees) in the RMSD field. It means that torsions that differs less 
than 60 degrees are considered similar.

• Click the Edit torsion button and select the flexible torsions as explained 
for the conformational search.

• Click Ok and save the clustered trajectory with the default name 
(imipramine_clust.dcd) and the default file format (DCD).

• The number of unique conformations is 55 (the starting number was 
1296).



Analysis of the property space1

Some molecular properties are related to the conformations and can influence 
biological effects (activity, metabolism, etc). Now we calculate the Polar Surface 
Area (PSA) for each conformation in the cluster analysis trajectory. The PSA is 
considered a measure of the capability to do hydrogen bonds.

• Open the Trajectory analysis window (Calculate → Analysis) and open the 
file imipramine_clust.dcd, clicking the envelope button or dragging & 
dropping the file over the Trajectory analysis window.

• Choose the Calculation tab and in the Property field, select Polar surface 
area (PSA).

• Click the Ok button and look the output in the VEGA ZZ console:

Starting PSA       : 1.4 Å²
Range              : 0.0000 (3) <-> 7.4256 (8)
Average value      : 3.0439 ±2.7524

It means that the conformation 3 don’t have any accessible polar atom and 
the conformation 8 has the maximum accessibility of polar atoms.



Analysis of the property space2

These results can be visualized calculating the PSA for both conformations.

• Close the Graph and reopen the Trajectory analysis window.

• Choose the Selection tab and in the Frame number field, put 3. The 
conformation 3 will be automatically selected.

• In the main menu, choose Calculate → Surface and the Surface manager
windows will be shown.

• In the New tab, select Solid, PSA in the Type field and check Color by 
gradient.

• Click the Calculate button and the PSA surface will be calculated. It 
appears completely blue and it means that is totally apolar.

• Remove the surface, clicking Remove all in the Surface management
window and repeat the same steps for the conformation 8.



Analysis of the property space2

Conformation 3 Conformation 8

PolarApolar

• Repeat the same calculation for the Molecular lypophilicity (MLP).



Molecular dynamics1

The molecular dynamics (MD) is another approach to do the conformational space 
analysis.

• Open the imipramine.iff molecule replacing the content of the current 
workspace.

• Assign the CHARMM atom types (Calculate → Charge & Pot.), checking 
Force field, unchecking Charges and selecting CHARMM. Click the Fix
button.

• Save the molecule as imipramine_dyn.iff in IFF format (File → Save As…)

• Open the NAMD dialog window (Calculate → NAMD), select the Other tab 
and in the Presettings box, double click on Dyn – 100 ps langevin 300K to 
load the settings required to perform a MD of 100 ps in a thermostatic 
bath at temperature of 300 K.

• Click the Run button and the Missing parameter table is shown because 
three parameters aren’t included in the force field.

• In the menu of that window, select Edit → Auto assign and click Ok.



Analysis of the molecular dynamics results1

• Wait the end of the calculation.

• Open the imipramine_dyn.dcd file (File → Open).

• In the Selection tab, click the Energy Graph button to watch the potential 
energy plot:

• This plot seems to not contain interesting information.



Analysis of the molecular dynamics results2

• In the Trajectory analysis window, choose the Measure tab, and click the 
Edit button. The Selection tool will be shown.

• Choose Distance in the selections field and click the Add button.

• In the main window, click on both nitrogens and finally click Done in the 
Selection tool.

• In Trajectory analysis, click the Ok button and the following graph is 
shown:

Conformational
transition

Calculate → Noise 
reduction → 75 %



2D editing

To build a small molecule as amitriptyline, you can use a 2D molecular editor as 
ISIS/Draw 2.5 that must be installed on your PC to use it inside VEGA ZZ.

• In the ISIS/Draw environment, edit 
the amitriptyline.

• To transfer the molecule to VEGA 
ZZ, choose VEGA ZZ → Send to 
VEGA in the ISIS/Draw menu. The 
2D structure will be automatically 
converted to 3D.

• Repeat all steps as for imipramine.

• Make sure that the workspace is empty. If isn’t true, select File → New in 
the main menu.

• Open ISIS/Draw, selecting Edit → ISIS/Draw.



Virtual screening
with VEGA ZZ and GriDock



What you need

• VEGA ZZ release 2.3.0 or greater.

• NAMD for Windows (click here to download it).

• GriDock 1.0.0 virtual screening software for Windows.

• AutoDock 4 and AutoGrid 4 molecular docking package.

• Accelrys CHARMM 22 parameter files (PARM.PRM).

• Test protein. In this tutorial will be used the crystallographic structure of 
the HIV-1 protease complexed with VX-478, a potent inhibitor (1HPV) 
available at Protein Data Bank (www.rcsb.org).

• One or more databases of 3D molecules in SDF or Zip format. They can 
be downloaded for free at http://ligand.info.



Download of the target protein

Download the HIV-1 protease structure (1HPV) through the PDB Web interface or 
the tool integrated in VEGA ZZ: 

• Start VEGA ZZ and select the File → PDB download menu item.

• Put 1HPV in the PDB Id field and click Download. At the download end, 
the protein structure will be shown in the workspace.

• Normalize the coordinates in order to translate the protein at the origin of 
the Cartesian axis (Edit → Coordinates → Normalize).

• Save the molecule (File → Save As) with the 1HPV_orig file name. It's 
strongly recommended the use of the IFF/RIFF file format because it's 
able to keep the maximum number of information (e.g. atom types,
charges, bond orders, etc).



Protein preparation1

It may be possible that the hydrogens are incorrectly added to the co-crystallized 
ligand due to the protein-specific algorithm and the unusual geometry that the ligand 
could assume in the binding pocket.

• Add the hydrogens (Edit → Add → Hydrogens), selecting Protein in the 
Molecule type box to enable an extra check for the atom hybridization, 
Residue end in the Position of hydrogens box and checking Use IUPAC 
atom nomenclature. Finally, click Add to place the hydrogens.

• Show the Atom selection window (View → Select → Custom), select 478 
in the Residue column and click the + button. Four carbons in one 
benzene ring have a wrong valence and four hydrogen atoms must be 
removed.

• Select Edit → Remove → Atom and click on the hydrogens to remove and 
close the dialog window pressing the Done button.



Protein preparation2

Benzene ring
with wrong hydrogens

Hydrogens to remove

Co-crystallized ligand



Protein preparation3

To optimize the structure that we completed adding the hydrogens, atomic charges 
and the atom potentials must be assigned. 

• Fix atom types and charges (Calculate → Charge & Pot.), checking Force 
field and Charges and selecting CHARMM and Gasteiger. Click the Fix
button. The total charge is 4.

• Save the molecule in IFF format as 1HPV.iff.

Now we are ready to run the NAMD 
minimization, but in order to preserve the 
starting experimental structure, we need to 
constraint the protein backbone which 
coordinates will be kept fixed during the 
calculation. 



Protein minimization1

• Select all atoms (VIew → Select → All).

• In the main menu, choose Edit → Coordinates → Constraints and select 
Fix in the Mode box and Protein  backbone in the Selection box. Finally 
click the Apply button. The fixed atoms (the backbone) will be colored in 
blue and the free atoms in green. Close the Constraint options window.

Fixed atoms
Fixed atoms



Protein minimization2

• Open the NAMD dialog window (Calculate → NAMD), select the Other tab 
and in the Presettings box, double click on Min - Atom fixed to load the 
settings required to perform an energy minimization with atom fixing.

• Go to the Basic tab and set the Number of timesteps in the Timestep
parameters box to 10,000.

• Clicking the Run button, the Missing parameter table is shown, because 
three ligand improper angles aren't included in the force field parameters. 
Click the Ok button without to fix the problem because the ligand will be 
removed from the binding pocket and thus its geometry isn't interesting for 
the screening.

• At the end of the calculation, save the refined structure as 1HPV_min.iff.



Input files for GriDock1

The crystallization water molecules aren't need and can create problems because 
they are considered fixed and can't be moved by the ligand during the docking 
calculation.

• To remove the water, select Edit → Remove → Water in the main menu.
In order to generate complexes in which the ligand is placed in the same pocket of 
the co-crystallized one, you need to select the atoms included in a sphere of 10 Å
radius centered on the binding site.

• Find all molecules in the complex, selecting Edit → Molecules → Fix. 
Three molecules will be found.

• Select the ligand (View → Select → Molecule), choosing the third molecule 
and clicking the Select button. The co-crystallized ligand will be shown.

• Open the Atom selection window (View → Select → Custom) and choose 
the Proximity tab. In the What box, select Atoms, in the Around box, select 
Molecule and click on one atom of the molecule in the workspace. Put 10
in the Radius field and finally click the + button.



Input files for GriDock2

• Remove the ligand to create enough space to dock the new molecules: 
choose Edit → Remove → Molecule, select the third molecule and click 
the Remove button.

To run virtual screenings with GriDock, the receptor structure must be pre-
processed assigning the AMBER atom types, fixing the atom charges, removing the 
apolar hydrogens and saving the molecule in PDBQT format. All these steps are 
automatically performed by AutoDock\Receptor.c script.

• Run the AutoDock\Receptor.c script (File → Run script → AutoDock →
Receptor.c).

• Create the Screening subdirectory, go inside it.

• Put 1HPV.pdbqt in the file requester and click Save.

• When the message Do you want run AutoGrid ? is shown, click Yes and 
wait the end of the calculation.

• The calculation is finish, when the AutoGrid console window disappears.



Database download

• Connect to http://ligand.info with your preferred Web browser.

• Download the ChemBank subset in zip format. This database is small and 
contains 2,344 molecules.

• Unzip the archive in the Screening directory.

• Rename the ligand_info_subset_1.sdf file to ChemBank.sdf.

GriDock requires one or more databases that must manageable by VEGA (SDF or 
Zip format) and they must contain the 3D structures of the molecules that you want 
to screen. You can build your own databases using the tools included in VEGA ZZ, 
you can convert a database from 2D to 3D through the Database 2D to 3D.c script 
or you can download one from Web sites as Ligand.Info: Small-Molecule Meta-
Database (http://ligand.info). In this tutorial, a small database will be downloaded 
from the that Web site.



Database check

• In the main menu, select File → Database → Open, go to the Screening
directory and double click on ChemBank.sdf. The Database explorer
window will be shown.

• To extract/visualize one molecule, just double click on its name in the 
Molecule list or click on the name and click the Get button (the return key 
has the same function).

• To close the database, click on ChemBank.sdf in the Database column 
and press the Close button.

If you want check the database, you can open it with VEGA ZZ:



Evaluation of the starting complex1

• In VEGA ZZ, open  the refined structure (1HPV_min.iff file).

• Remove the water (Edit → Remove → Water).

• Remove the first two segments (Edit → Remove → Segment). Now in the 
workspace, only the ligand is present.

• Run the AutoDock\Ligand.c script and save the ligand as Ligand.pdbqt in 
the Screening directory.

In order to compare the screening results with the co-crystallized ligand, it may be 
interesting to evaluate the complex interaction energy. As first step, you need to 
extract the ligand from the crystal structure.

WARNING:

Don't normalize the ligand atom coordinates because you need to preserve the 
starting position.



Evaluation of the starting complex2

• Open the VEGA console (Start → VEGA ZZ → VEGA console).

• Change the current directory  to the working directory (Screening) by the 
cd command.

• In the console type:

gridock -t score.dpf 1HPV.pdbqt Ligand.pdbqt

• the -t option is used to select another input template file for AutoDock 4. 
The score.dpf template keeps the starting position and conformation of the 
ligand and evaluate the interaction energy.

• When the calculation is finished, looking inside the log or the 
1HPV_Ligand.csv file, it's possible to read the interaction energy and the 
Ki of the best complex.

To calculate the interaction energy between the co-crystallized ligand and the HIV-1 
protease:



Log output file

16:31:33 ************************
16:31:33 INIT: GriDock 1.0.0.21 started on Windows
16:31:33 INIT: Local time Mon, 09 Mar 2009 17:31:33
16:31:33 INIT: Cpu model: AMD Athlon(tm) MP 2200+
16:31:33 INIT: CPUs/Cores detected: 2
16:31:33 INIT: CPUs/Cores used: 1
16:31:33 INIT: AutoDock/VEGA directory: "X:\Lcc\Veg a"
16:31:33 INIT: AutoDock executable: "X:\Lcc\Vega\Au toDock4.exe"
16:31:33 INIT: VEGA executable: "X:\Lcc\Vega\Vega.e xe"
16:31:33 INIT: Receptor file: "1HPV.pdbqt"
16:31:33 INIT: Database file: "Ligand.pdbqt"
16:31:33 INIT: AutoDock template file: "X:\Lcc\Vega \Data\Autodock\score.dpf"
16:31:33 INIT: AutoDock output archive: "1HPV-Ligan d_01.zip"
16:31:33 INIT: Max. size of AutoDock output archive : 4000000000 bytes
16:31:33 INIT: Energy output file: "1HPV-Ligand.csv "
16:31:33 INIT: Energy output delay: 300 sec.
16:31:33 INIT: Temporary file directory: "C:\DOCUME ~1\ADMINI~1\IMPOST~1\Temp"
16:31:33 INIT: First molecule to dock: 1
16:31:33 INIT: Input database in PDBQT format: one molecule only will be docked
16:31:33 INIT: AMMP time-out: 120 sec.
16:31:33 INIT: AutoDock time-out: 12000 sec.
16:31:33 INIT: VEGA time-out: 120 sec.
16:31:34 INFO: Starting AutoDock - Molecule 1 (Ligan d)
16:31:36 INFO: Molecule 1 - Docking finished (0m 2s)
16:31:36 DOCK: Molecule 1 - Best model 1, Best Binding energy = -8.55 kcal/mol, Ki = 543.74 uM
16:31:36 INFO: Energy file updated
16:31:36 INFO: End of calculation
16:31:36 INFO: Docked molecules 1
16:31:36 INFO: Elapsed time 0h 0m 3s



CSV output file

Database; MolID; Pose; Ki; Binding; Intermolecular; VdW + Hbond + Desolv; Electrostatic ; 
Internal; Torsional; Unbound; Molecule name

Ligand; 1; 1; 543,74; -8,55; -10,26; -9,63; -0,62; -1,31; 3,02; 0,00; Ligand

The same information van be found in the 1HPV_Ligand.csv file, but it's formatted to 
be managed by a spreadsheet (e.g. Excel):

• Extract the file 1HPV-Ligand_00000001.dlg from the 1HPV-Ligand_01.zip 
archive to the Screening directory.

• Open the extracted file with VEGA ZZ. The Trajectory analysis window is 
shown, but you can't do anything because only one complex is included in 
the output.

• Close the Trajectory analysis window, clicking the Cancel button.

• To highlight the ligand, color the structure by molecule (View → Color →
By molecule): the ligand will be painted in red and the enzyme in white.

If you want visualize the resulting complex: 



Running the screening

• To start the virtual screening, type in the command prompt:

gridock 1HPV.pdbqt ChemBank.sdf

• and hit return. The time required to screen all 2,344 molecules contained 
in the ChemBank.sdf database depends on the computational power of 
your system. It's possible to check the calculation progress, viewing the 
log file (gridock_YYYYMMDD.log) with a text editor.

• If you want to screen a limited number of molecules and not the entire 
database, you can specify the starting and the ending molecule numbers:

gridock -f 10 -l 200 1HPV.pdbqt ChemBank.sdf

the molecules in the range from 10 to 200 will be screened only. If you 
want start from the first molecule, the -f option can be omitted.

gridock -l 200 1HPV.pdbqt ChemBank.sdf



Results

• You can consider ligands as potential HIV-1 protease inhibitors when the 
binding energy and/or the binding constants (Ki) are respectively less than 
-8.55 kcal/mol and 543,74 µM.

• Considering the molecules from 1 to 200 in the ChemBank database and 
analyzing the 1HPV-ChemBank.csv file, you can obtain these results:

Database; MolID; Pose; Ki; Binding; Intermolecular;  VdW + Hbond + Desolv; Electrostatic; Internal; Torsi onal; 
Unbound; Molecule name

ChemBank; 123; 10; 54,31; -9,91; -9,91; -9,69; -0,2 2; 0,00; 0,00; 0,00; Paxilline

ChemBank; 12; 7; 606,27; -8,48; -9,10; -8,99; -0,11 ; -1,20; 1,10; -0,71; BML-190

ChemBank; 151; 2; 747,69; -8,36; -8,84; -8,67; -0,1 7; -0,39; 0,55; -0,33; Go6976

ChemBank; 131; 4; 795,11; -8,32; -8,75; -7,59; -1,1 6; -0,35; 0,55; -0,23; AM-580

ChemBank; 101; 4; 1,07; -8,15; -8,91; -8,90; -0,01;  -0,65; 0,82; -0,59; 24,25-Dihydroxyvitamin D3

ChemBank; 75; 4; 1,08; -8,14; -8,14; -8,16; 0,02; 0 ,00; 0,00; 0,00; Grayanotoxin III

ChemBank; 125; 3; 1,54; -7,93; -8,44; -8,17; -0,28;  -0,41; 0,55; -0,38; PCO-400

ChemBank; 133; 2; 1,79; -7,84; -8,44; -8,13; -0,31;  -0,36; 0,55; -0,42; TTNPB

ChemBank; 97; 10; 2,02; -7,77; -8,83; -8,78; -0,05;  -0,35; 0,82; -0,59; 25-Hydroxyvitamin D3

ChemBank; 99; 9; 2,20; -7,72; -8,46; -8,42; -0,04; -0,66; 0,82; -0,58; 1,25-Dihydroxyvitamin D3

ChemBank; 31; 9; 2,45; -7,65; -7,65; -7,57; -0,08; 0,00; 0,00; 0,00; Cyclopiazonic Acid

ChemBank; 119; 1; 2,51; -7,64; -7,64; -7,67; 0,03; 0,00; 0,00; 0,00; 6-Formylindolo [3,2B] Carbazole

ChemBank; 107; 8; 2,76; -7,58; -8,62; -8,05; -0,57;  -0,70; 1,10; -0,64; 13-Cis Retinoic Acid


